Common Xero Exceptions

Common Xero Exceptions

Here you will find a list of common exceptions that raised by the system's integration with Xero. 




Exceptions for Sales Invoices / Credit Notes

These are common exceptions generated when syncing a sales invoice or credit note with Xero. 

Idea
To resend a sales invoice to xero once and issue has been resolved: 
  1. Set the invoice state to something other than issued, if it is currently issued 
  2. Set the invoice state to issued to trigger the sync operation 
  3. Set the invoice state to the original state if it was not issued.


The Account Number already exists. Please enter a different Account Number.

Common Cause: 
  1. Name Mismatches: A mismatch between the company name in CocoonOPS system and Xero may cause the Xero to attempt to create a "new" contact using a number that already belongs to the existing one.

How To Resolve: 
  1. Check that the name for the contact and organisation match with that in Xero where the contact already exists
  2. Check the the billing account code matches 


 Invoice # must be unique

Common Cause: 
  1. The invoice reference already exists in your Xero instance

How To Resolve: 
  1. If the invoice exists in Xero and is correct, close the exception in CocoonOPS

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